La machine

Il s'agit d'un P4 2,8GHz, avec 512Mo de mémoire, un disque dur de 60Go et surtout une carte graphique NVidia GeForce FX Go5600 avec 64Mo de mémoire dédiée. L'écran est un 15 pouces, et, comme d'habitue sur les VAIO, magnifique grace à la techno X-Black. J'ai choisi ce modèle car je cherchais avant tout un remplaçant pour mon PC desktop pour les vacances, et pas un super-ultra-mega-portable de 3 grammes avec 6 heures de batterie et un clavier qu'il faut taper avec des cure-dents.

A priori, à part quelques bidouilles proprio made in Sony dont je n'ai cure (comme le lecteur de Memory Stick), le matériel est donc plutôt standard et bien supporté par Linux (ce n'était pas le cas à sa sortie...).

Préparation

Avant d'installer Linux, j'ai utilisé le DVD de restauration fourni avec l'ordinateur afin de repartitionner le disque. Il est théoriquement possible de redimensionner les partitions au moment de l'installation de Linux, mais je n'ai que moyennement confiance dans ce système, et de toutes façons le Windows avait atteint sa date de péremption (soit environ 1 an) : c'était donc l'occasion de le réinstaller.

Après avoir redémarré avec le DVD, j'ai utilisé l'option « Modifier la taille des partitions » (ou quelque chose comme ça), pour créer un disque C de 20Go et un disque D avec le reste.

Installation

Après avoir gravé un CD de Ubuntu 6.10 (répondant au doux nom de « Edgy Eft », littéralement « triton énervé » et redémarré le PC, premier obstacle : ça marche pas ! En fait, ça démarre bien, mais ça freeze au bout d'un certain temps (de quelques secondes à plusieurs minutes), ce qui m'empeche d'aller au bout de l'installation.

Pour solutionner ce problème, il faut ajouter des options magiques au démarrage. En appuyant sur F6 au moment où le CD démarre, ajouter :

noapic nolapic

Bien, maintenant que ça ne plante plus, je peux partitionner le disque correctement. J'ai supprimé la partition D créée par l'installeur de Windows pour la remplacer par une deuxième partition primaire (hda2) d'environ 1Go (pour le swap), une troisième partition primaire (hda3) d'environ 15Go (qui accueillera le système) et le reste sous forme de partition logique (hda5) d'environ 24Go (l'espace restant quoi), en FAT32 (type 0C si l'installeur pose la question) qui contiendra mes documents, partagés entre les deux systèmes. Petit résumé :

Disque        Taille   FS     Correspond à
/dev/hda1        19G   NTFS   C: (/media/windows)
/dev/hda2         1G   Swap   swap
/dev/hda3        14G   Ext3   /
/dev/hda5        23G   Fat32  /media/documents

En voulant valider, je me heurte à un deuxième problème : l'installeur d'Ubuntu rale parceque selon lui il n'y a « pas de système de fichier racine » (ce qui est evidemment faux). Pour corriger ce problème, j'ai du modifier le script d'installation selon les instructions de ce message. Pour les non-anglophones (les pauvres), il s'agit de remplacer, dans le fichier

/usr/lib/ubiquity/ubiquity/validation.py
les lignes :

if not root:
  result.add(MOUNTPOINT_NOROOT)

par :

if not root:
  pass

Il faut faire cette manipulation en tant que root (avec sudo par exemple) puis relancer l'installeur.

Après toutes ces péripéties, le système s'installe enfin correctement !

Après l'installation

Une fois ubuntu installé correctement, je n'ai rencontré aucun problème particulier, si ce n'est le reboot qui ne fonctionne pas (l'ordinateur reste allumé, il faut appuyer sur le bouton). Vu que l'arrêt fonctionne, ça ne me dérange pas vraiment donc je n'ai pas cherché à en savoir plus.

J'ai installé sans aucun problème les drivers propriétaires de NVidia afin de bénéficier de l'accélération 3D, pour pouvoir notamment utiliser Beryl (un bureau en 3D). Vous trouverez toutes les infos nécessaires sur l'excellent le tutorial Beryl du site Ubuntu Fr.

Concernant les polices de caractères, j'ai évidemment réduit la taille, désactivé l'anti-aliasing, et installé les polices Microsoft par défaut (oui Microsoft c'est mal, mais là c'est tellement plus joli...).

Il reste quelques trucs qui me chiffonnent et que je n'ai pas eu le temps de regarder :

  • J'ai l'impression que le ventilateur tourne beaucoup plus quand je suis sous Linux que sous Windows, peut-être un problème d'ACPI ?
  • Les boutons du portable (volume, luminosité de l'écran, etc.) ne fonctionnent pas, mais je pense que ça doit être possible de les binder.
  • Comme expliqué ci-avant, le reboot devrait fonctionner, peut-être une option de démarrage à modifier.